Habt ihr auch “Comparison method violates its general contract” (bei Eclipse)?

Für Eclipse 3.6 möchte ich gerade die ersten Plugins installieren (SVN-Client und Google Eclipse Plugin) und bekomme ein “Comparison method violates its general contract”. Der Fehler kommt aus einer neuen Implementierung TimSort fürs Sortieren, http://cr.openjdk.java.net/~martin/webrevs/openjdk7/timsort/src/share/classes/java/util/TimSort.java.html zeigt die Implementierung. Kennt ihr das Problem? Google kennt das Problem nicht wirklich.

Ähnliche Beiträge

4 Gedanken zu “Habt ihr auch “Comparison method violates its general contract” (bei Eclipse)?

  1. Ich wünschte ich hätte für jeden meiner Versuche, Eclipse über mehrere Tage stabil mit den von mir gewünschten Plugins und ohne un- oder schlecht dokumentierte Fehlermeldungen zu betreiben, nen Euro von der Foundation kassiert. Seit 2010 bin ich bei Netbeans gelandet und ein sehr, sehr glücklicher Entwickler mit ner Menge Freizeit. Viel Glück bei der Suche nach der Lösung!(btw: Tolles Java-Buch!!)

  2. Was ist das für ein unpassender Kommentar? Ich wünschte ich würde einen Cent bekommen, für alle das Thema verfehlenden oder eine Antwort schuldig bleibenden Posts 🙂

    Der Fehler hängt auch wirklich an JRE/JVM 7. Nachdem ich diese wieder deinstalliert hatte (bzw. v6 als Standard gesetzt habe), funktionierte mein Eclipse wieder reibungsfrei. Danke Christian! (auch für dein Buch)

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.